1

VS 2010: Pakete werden nicht ordnungsgemäß geladen

Das „RadLangSvc.Package, RadLangSvc.VS, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91“-Paket wurde nicht ordnungsgemäß geladen. Solltet ihr auch von Fehlermeldungen dieser Art geplagt werden und eine Reparatur von Visual Studio keinen Erfolg gebracht haben, dann schnappt euch eure Installations DVD und installiert die folgenden Pakete nach. Zu finden sind sie im Pfad x:\WCU\DAC. DACFramework_deu.msi DACProjectSystemSetup_deu.msi TSqlLanguageService_deu.msi Die Meldungen sollten, nach der Installation, verschwunden sein.

Eclipse: Ordner und Dateien im Windows Explorer anzeigen

Wie oft muss man während der täglichen Arbeit den Explorer in einem bestimmten Projektverzeichnis öffnen? Zumindest so oft, das sich die folgende Konfiguration als sehr nützlich und zeitsparend erwiesen hat. Klickt im Eclipse Fenster auf dem Pfeil, der neben dem Button zum Starten der externen Programme ist (Bild), und wählt „External Tools Configurations…“ aus Klickt, in dem neu geöffneten Fenster, …

PHP + PDT: Probleme bei der Installation des Zend Debuggers

Wer derzeit versucht den Zend Debugger über die Update Seite zu installieren, wird das Problem bereits bemerkt haben. Es funktioniert nicht. Scheinbar haben sich vor einiger Zeit die Dateinamen/Versionen geändert, aber es wurde versäumt die Update Seite zu kontrollieren. Während der Installation versucht Eclipse Dateien herunterzuladen die es auf dem Server nicht (mehr) gibt. Was kann man also machen? Die …

PHP + PDT: Probleme mit Autocomplete unter Eclipse Helios und PDT 2.2

Wer derzeit das neue PDT Paket testet, wird vielleicht unter dem gleichen Problem leiden. Autocomplete will nicht richtig funktionieren. Ich drücke STRG+Leertaste und kriege nur eine leere Liste. Sascha hat in seinem Software-Entwickler Blog eine Lösung veröffentlicht, mit der man das Problem beheben kann. Wie jedoch dem verlinkten Beitrag im Zend Forum zu entnehmen ist, klappt das nicht bei jedem. …

Sharepoint Server 2010 Beta auf Windows Server 2008 R2 installieren

Wer den Sharepoint Server 2010 auf einem Windows Server 2008 R2 installieren möchte, wird spätestens beim Konfigurations-Assistenten ein Problem bekommen. Beim achten Schritt meldet der Assistent, das eine Ausnahme vom Typ Microsoft.Office.Server.UserProfiles.UserProfileException aufgetreten ist und er das Attribut allowInsecureTransport nicht kennt. Der Assistent beendet sich und bittet um die Behebung des Problems. Microsoft bietet über Microsoft Connect einen entsprechenden Hotfix …

1

PHP: Getter und Setter mit PDT generieren

Eine Möglichkeit, automatisch Getter und Setter mit PDT zu generieren, habe ich noch nicht gefunden. Mit dem unten genannten Code, könnt Ihr das Erstellen von Gettern und Settern mit PDT aber beschleunigen. Erstellt hierzu ein neues Code Template (Window -> Preferences -> PHP -> Editor -> Templates) und gebt ihm den Namen ‚get‘. In das Feld Pattern, fügt ihr den …

3

PHP: Smarty + Eclipse PDT

Für alle die Eclipse PDT nutzen, und den Smarty Support bis dato schmerzlich vermisst haben, gibt es eine gute Nachricht. Unter http://code.google.com/p/smartypdt/ ist eine neue Version von SmartyPDT erschienen, welches nun auch mit aktuellen PDT und Eclipse Versionen kompatibel ist. Die Installation ist spielend einfach: Ladet euch das ZIP Archiv herunter Öffnet Eclipse und wechselt in das Menu Help -> Install …

3

Lighttpd 1.4: HTTP 417 Expectation Failed

Versucht man mit einer cURL oder .NET Anwendung POST Daten an einen Lighttpd 1.4 Server zu senden, bekommt man die Meldung

Dies liegt daran, das die Programme einen Expect: 100-continue Header senden, und als Antwort 100 (Continue) oder 417 Expectation Failed erwarten. Lighty kennt den Header jedoch nicht, und antwortet deswegen mit dem besagten 417 Expectation Failed. Der Expect: …

1

Windows 7: God Mode

In Windows 7 ist eine hübsche Übersicht über viele Einstellmöglichkeiten versteckt. Um diese zu betreten, erstellt einfach einen neuen Ordner und vergebt den folgenden Namen: (GodMode könnt ihr durch einen beliebigen Text ersetzen, der Rest muss so bleiben)

Das Symbol sollte sich nun ändern, und nach einem Doppelklick darauf, öffnet sich die versprochene Übersicht.

VMware: Patches für den 2.6.30 Kernel

Der 2.6.30 Kernel ist im kommen, aber VMware Server und Workstation lassen sich darauf nicht installieren. Schade eigentlich. Wäre da nicht eine aktive Community. Die User michelemase und Krellan haben Patches im VMware Forum veröffentlicht, die das kompilieren der Kernel Module wieder ermöglichen. Links: Patch für den VMware Server Patch für die VMware Workstation