1

PHP 7.0: Could not gather sufficient random data

Aufgrund eines Fehlers in der Version 7.0.16 von PHP kann es zu der unerwarteten Meldung Could not gather sufficient random data  kommen, wenn man random_bytes  oder random_int  nutzt. Das Problem tritt auf, wenn PHP auf einem aktuellen Kernel kompiliert wurde und anschließend auf einem älteren Kernel ausgeführt wird, welcher die Systemfunktion getrandom  noch nicht unterstützt. Aktuelle Möglichkeiten dem Problem aus dem Weg zu gehen: Update auf PHP >= 7.1.0 Downgrade …

1

Symfony2: Could not parse object ‚303b8a83c87d5c6d749926cf02620465a5dcd0f2‘

Beim updaten meiner Projekte auf Symfony 2.0.1 ist mir eben die folgende Fehlermeldung ins Auge gestochen:

Scheinbar gibt es Probleme beim Aktualisieren von monolog. Alle anderen Abhängigkeiten werden ordentlich aktualisiert. Was kann man tun? Ein kurzer Blick in die Ankündigung bringt auch schon die Lösung. Löscht einfach den Ordner vendor/monolog und führt noch einmal bin/vendors install aus. Monolog sollte jetzt …

1

Windows/TortoiseGit: Ordner wird verwendet

Wir Windows User machen uns das Leben echt einfach. Für alles muss eine GUI her. Konsole? Ihh, nää, kann ich nicht. Ich brauch eine schicke Oberfläche. Das gilt natürlich auch bei der Arbeit mit der Versionsverwaltung. Selbst wenn es sich um Git dreht, das man eigentlich nur auf der Konsole richtig nutzen kann. Nein, auch da muss eine GUI her, …

1

VS 2010: Pakete werden nicht ordnungsgemäß geladen

Das „RadLangSvc.Package, RadLangSvc.VS, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91“-Paket wurde nicht ordnungsgemäß geladen. Solltet ihr auch von Fehlermeldungen dieser Art geplagt werden und eine Reparatur von Visual Studio keinen Erfolg gebracht haben, dann schnappt euch eure Installations DVD und installiert die folgenden Pakete nach. Zu finden sind sie im Pfad x:\WCU\DAC. DACFramework_deu.msi DACProjectSystemSetup_deu.msi TSqlLanguageService_deu.msi Die Meldungen sollten, nach der Installation, verschwunden sein.

PHP + PDT: Probleme bei der Installation des Zend Debuggers

Wer derzeit versucht den Zend Debugger über die Update Seite zu installieren, wird das Problem bereits bemerkt haben. Es funktioniert nicht. Scheinbar haben sich vor einiger Zeit die Dateinamen/Versionen geändert, aber es wurde versäumt die Update Seite zu kontrollieren. Während der Installation versucht Eclipse Dateien herunterzuladen die es auf dem Server nicht (mehr) gibt. Was kann man also machen? Die …

3

Lighttpd 1.4: HTTP 417 Expectation Failed

Versucht man mit einer cURL oder .NET Anwendung POST Daten an einen Lighttpd 1.4 Server zu senden, bekommt man die Meldung

Dies liegt daran, das die Programme einen Expect: 100-continue Header senden, und als Antwort 100 (Continue) oder 417 Expectation Failed erwarten. Lighty kennt den Header jedoch nicht, und antwortet deswegen mit dem besagten 417 Expectation Failed. Der Expect: …

[PHP] Wenn der Kanarienvogel nicht mehr zwitschert

Wer sich wundert warum seine PHP Skripte ohne ersichtlichen Grund einen HTTP 500 Internal Server Error liefern, sollte einmal prüfen ob Suhosin aktiv ist. Dieser Auszug stammt von einem unserer Debian Server und repräsentiert in jeder Zeile einen HTTP 500 Error.

Was ist passiert? Suhosin versucht Attacken auf Sicherheitslücken in PHP bzw. PHP Skripten zu erkennen und zu verhindern. …